Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Geld allein macht nicht glücklich - benutzt kivitendo!

+1 Punkt

Hallo zusammen,

ich habe aktuell ein Kivitendo in der Version 3.5.1 auf der aktuellen Debian Version 9.3 Stretch installiert, leider scheitert jedes Mal die Umwandlung der OO-Vorlagen in eine PDF mittels Libreoffice 5.2.7-1. Apache Log gibt mir folgendes aus:

Warning: -minimized is deprecated.  Use --minimized instead.
Warning: -norestore is deprecated.  Use --norestore instead.
Warning: -nologo is deprecated.  Use --nologo instead.
Warning: -nolockcheck is deprecated.  Use --nolockcheck instead.
Warning: -headless is deprecated.  Use --headless instead.
Warning: -accept=socket,host=localhost,port=2002;urp; is deprecated.  Use --accept=socket,host=localhost,port=2002;urp; instead.
Error: sales_quotation.odt : Conversion from OpenDocument to PDF failed because OpenOffice could not be started.

Libreoffice lässt sich manuell unproblematisch ansteuern, eine "händische" Konvertierung von .odt zu PDF läuft problemlos. Xvfb ist ebenfalls ansprechbar.

Rechte mit chown für www-data liegen auf allen Ordnern (webdav, spool, users).

Config Datei verweist auf die richtigen Pfade. Mit der exakten Konfiguration konnte ich Kivitendo unter Debian Squeeze und Jessy ohne weiteres betreiben, inklusive OO zu PDF Konvertierung.

Hat hier ggf. noch jemand eine Idee? Vielleicht eine Stelle, wo ich dir zu übergebenden Parameter manipulieren kann? Ich bedanke mich vorab für jeglichen Input!

Grüße,
D. Burow

Gefragt von (30 Punkte)

2 Antworten

0 Punkte

Hallo Zusammen,

ich weiß das der Beitrag schon älter ist und ich stehe genau vor den gleichen Problem.

@dburow : Konnte das Problem schon gelöst werden?

Mein System:
Debian 10.6 Buster
Update: kivitendo v3.5.6.1
Apache2 2.4.38
Xvfb 1.20.4
Libreoffice 6.1.5.2

Fehler:

/var/log/apache2# tail -f error.log
Warning: -minimized is deprecated.  Use --minimized instead.
Warning: -norestore is deprecated.  Use --norestore instead.
Warning: -nologo is deprecated.  Use --nologo instead.
Warning: -nolockcheck is deprecated.  Use --nolockcheck instead.
Warning: -headless is deprecated.  Use --headless instead.
Warning: -minimized is deprecated.  Use --minimized instead.
Warning: -norestore is deprecated.  Use --norestore instead.
Warning: -nologo is deprecated.  Use --nologo instead.
Warning: -nolockcheck is deprecated.  Use --nolockcheck instead.
Warning: -headless is deprecated.  Use --headless instead.

Ich habe das ganze auch mit Apache OpenOffice 4 getestet und bekomme dort den selben Fehler.

Das Problem ist das LibreOffice und Apache OpenOffice 4 die Parameter geändert haben.

zum Beispiel:
Alt: -nologo
Neu: --nologo

Quellen:
Libreoffice Alte Parameter
Libreoffice Neue Parameter

Fehlermeldungen, Anregungen und Wünsche bitte senden an: empfang@revamp-it.ch

Ich werde auch diesen Fehler an die oben genannte E-Mail schreiben.

Für Informationen wäre ich dankbar.
Sollte ich mehr Infos haben werde ich nochmals Schreiben.

Mit freundlichen Grüßen
Track1991

Beantwortet von (240 Punkte)
+1 Punkt

Hallo Track1991

Zunächst mal zu den Apache-Fehlermeldungen: das sind ja nur 'warnings', deshalb sind die denke ich nicht daran Schuld, dass das PDF nicht erzeugt wird.
Diese Parameter werden im kivitendo-Code in der Datei SL/Template/OpenDocument.pm verwendet.
Um auszuschliessen, dass diese Warnings die Ursache des Problems sind, kannst du einfach in dieser Datei die Parameter statt mit einem mit zwei Bindestrichen versehen und dann die Umwandlung in ein PDF nochmals probieren.

Danke aber auf jeden Fall für den Hinweis, werde das in Kürze mal im kivitendo Code korrigieren.

Was das direkte Erstellen einer PDF-Datei in kivitendo auf der Basis von OpenDocument-Vorlagen betrifft, muss ich mich zuerst nochmals schlau machen, wir hatten das Problem auch schon.
Ich melde mich deswegen hier demnächst nochmals.

Gruss
Andreas

Beantwortet von (4.4k Punkte)

Danke für die schnelle Antwort.

Ich habe die Parameter unter Datei SL/Template/OpenDocument.pm geändert.
Leider aber noch nicht die Lösung. :-(

Werde morgen mal Lesen wie das unter Libreoffice geht und Probieren.

Ähnliche Fragen

0 Punkte
2 Antworten
0 Punkte
1 Antwort
+1 Punkt
1 Antwort
0 Punkte
1 Antwort
...