Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo,

habe gerade auf die neue kivitendo 3.5.4-beta via git upgedatet.

Erhalte beim Versuch eine AB zu mailen folgendes:

Fehler: Die E-Mail wurde aufgrund des folgenden Fehlers nicht verschickt: SMTP connection could not be initialized at /var/www/kivitendo-erp/SL/Mailer/SMTP.pm line 39.<br>

Wo muss ich drehen das es funzt?

Info, nutze Debian 10 mit php Version 7.2, config siehe unten:

[mail_delivery]
method = smtp
sendmail = /usr/sbin/sendmail -t<%if myconfig_email%> -f <%myconfig_email%><%end%>
host = localhost
host = mein websever adresse
port = 465
Gefragt von (2.3k Punkte)

1 Antwort

0 Punkte
 
Beste Antwort

Am Besten immer einen diff von der kivitendo.conf.default mit Deiner machen.

In der obigen Config ist der Host-Eintrag doppelt vorhanden, ferner fehlt der security Parameter.
security=ssl

Hier der aktuelle Eintrag:

[mail_delivery]
# Delivery method can be 'sendmail' or 'smtp'. For 'method = sendmail' the
# parameter 'mail_delivery.sendmail' is used as the executable to call. If
# 'applications.sendmail' still exists (backwards compatibility) then
# 'applications.sendmail' will be used instead of 'mail_delivery.sendmail'.
# If method is empty, mail delivery is disabled.
method = smtp
# Location of sendmail for 'method = sendmail'
sendmail = /usr/sbin/sendmail -t<%if myconfig_email%> -f <%myconfig_email%><%end%>
# Settings for 'method = smtp'. Only set 'port' if your SMTP server
# runs on a non-standard port (25 for 'security=none' or
# 'security=tls', 465 for 'security=ssl').
host = localhost
#port = 25
# Security can be 'tls', 'ssl' or 'none'. Unset equals 'none'. This
# determines whether or not encryption is used and which kind. For
# 'tls' the module 'Net::SSLGlue' is required; for 'ssl'
# 'Net::SMTP::SSL' is required and 'none' only uses 'Net::SMTP'.
security = none
# Authentication is only used if 'login' is set. You should only use
# that with 'tls' or 'ssl' encryption.
login =
password =
Beantwortet von (7.4k Punkte)
ausgewählt von

oje, die zwei host sind mir gar nicht aufgefallen, Danke, jetzt funzt es wieder.

sercurity = ssl sowie login und password sind und waren natürlich gesetzt.

Ähnliche Fragen

0 Punkte
3 Antworten
Gefragt 2, Jan 2013 von turtle (2.3k Punkte)
0 Punkte
2 Antworten
Gefragt 24, Mär 2013 von turtle (2.3k Punkte)
0 Punkte
3 Antworten
0 Punkte
1 Antwort
Gefragt 4 Aug von turtle (2.3k Punkte)
...