Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo Werner,

vielen Dank für deinen Tipp. Wie du vielleicht vermutest - ich kenne mich mich dem Webserver und apache2 nicht besonders gut aus. Was ich bräuchte ist einfach eine Minimalkonfiguration, sodass ich Kivitendo einfach nur zum Laufen bringe.

Ich habe im Netz viel gelesen und weiß jetzt, dass das im Kap. 2.6.1 der Installationsanleitung stehende "httpd.conf" dazu dient, die Datei apache2.conf nicht zu verändern und versehentlich zu zerstören, sondern stattdessen nur mittels Include eine andere Datei zu lesen.
Ich habe die Zeilen in Kap. 2.6.1 nun in eine neue Datei /etc/apache2/httpd.conf kopiert und in /etc/apache2/apache2.conf als letzte Zeie "Include httpd.conf" ergänzt. Dann mit /etc/init.d/apache2 relad den apache neu gestartet - Nichts! Im Browser wird der Aufruf localhost/kivitendo-erp-release-3.5.5/login.pl mit dem Download von login.pl quittiert. Funktioniert also nicht.
Ausprobiert habe ich noch die Pluszeichen vor den Parametern in der Zeile beginnend mit Options. Gleiches Bild (Download login.pl ... ).

Aber wie gesagt, das brauche eine Minimalkonfiguration. Wie soll das Vorgehen in Kap. 2.6.1 geändert werden, damit der apache2 läuft und login.pl ausgeführt wird, anstatt als Download angeboten zu werden?

/Alois

bezieht sich auf eine Antwort auf: login.pl führt zum Download-Dialog
Gefragt von (80 Punkte)

1 Antwort

0 Punkte

Die Konfiguration aus 2.6.2.4 der Doku hier schon auf Deine Daten angepasst

AddHandler fcgid-script .fpl
AliasMatch ^/kivitendo-erp/[^/]+\.pl /var/www/kivitendo-erp-release-3.5.5/dispatcher.fpl
Alias    /kivitendo-erp/ /var/www/kivitendo-erp-release-3.5.5
FcgidMaxRequestLen 10485760
<Directory /var/www/kivitendo-erp-release-3.5.5>
AllowOverride All
Options ExecCGI Includes FollowSymlinks
Require all granted
</Directory>
<DirectoryMatch /var/www/kivitendo-erp-release-3.5.5/users>
Require all denied
</DirectoryMatch>

nach /etc/apache2/conf-available/kivitendo.conf schreiben
Deine Konfiguration http.conf rückgängig machen

folgende Befehle ausführen

a2enmod fcgid
a2enconf kivitendo

vielleicht ist es auch a2enconf kivitendo.conf

apache neu starten bzw reloaden

service apache2 restart

und versuchen kivitendo im Browser über

localhost/kivitendo-erp/ aufzurufen

Oder den Dienstleister Deiner Wahl beauftragen sollte nicht die Welt kosten

Werner kivitendodienstleister

Beantwortet von (5.8k Punkte)

Ähnliche Fragen

...