Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo zusammen,

vielleicht kann mir hier jemand weiterhelfen: die Zeitzone auf dem Ubuntu-Server sind eigentlich auf CEST gestellt, der Taskserver ignoriert das aber, und protokolliert in UTC.

Beispiel:

root@248:~# date
Fri 19 Aug 2022 11:36:36 AM CEST

Apache-Log:

-rw-r--r-- 2 root          root  4353 Aug 19 11:35 access_ssl_log

und

185.89.39.78 - - [19/Aug/2022:11:35:06 +0200] "GET /controller.pl?action=BackgroundJob%2flist HTTP/1.0" 200 7942 "https://kivitendo.officeprojekt.xx/login.pl?action=company_logo" "Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0"

Der Taskserver läßt sich davon nicht beeindrucken:

Ausführungsart 	Aktiv 	Ausführungszeitplan 	Letzte Ausführung um 	Nächste Ausführung um
wiederholte Ausführung 	nein 	0 3 * * * 	niemals 	28.12.2018 03:00:00
wiederholte Ausführung 	ja 	*/5 6-21 * * * 	19.08.2022 09:35:00 	19.08.2022 09:40:00

Hat jemand vielleicht einen Tip?

Viele Grüße
Wolfram

Gefragt von (190 Punkte)

1 Antwort

0 Punkte

Die Datenbank hat vielleicht eine eigene abweichende Einstellung:

select name, setting, source from pg_settings where name ~* 'imez';

--           name          |    setting    |       source
-- ------------------------+---------------+--------------------
--  log_timezone           | Europe/Berlin | configuration file
--  TimeZone               | UTC           | session
--  timezone_abbreviations | Default       | default

oder (in psql):

 show timezone;

-- TimeZone
-- ---------------+
-- Europe/Berlin
-- (1 row)

Beantwortet von (16.8k Punkte)

Danke für den Hinweis. Ich habe daraufhin die beiden Ubuntu-Server gecheckt: beide haben die gleichen settings:

          name          |    setting    |       source       
------------------------+---------------+--------------------
 log_timezone           | Europe/Berlin | configuration file
 TimeZone               | Europe/Berlin | configuration file
 timezone_abbreviations | Default       | default

aber nur der virtuelle Server zeigt das auffällige Verhalten. Ich glaube im Augenblick nicht mehr, dass das Problem im Bereich der Datenbank liegt, weil Änderungen an Artikeln oder Aufträgen korrekt geloggt werden. (Tabellen parts, oe etc.) Da ist für itime now() als Standardwert gesetzt, für mtime dagegen nicht.

 Spalte 	Datentyp 	Nicht Null 	Standardwert
itime 	timestamp without time zone 	    	now()
mtime 	timestamp without time zone 	

Beide Einträge werden korrekt geschrieben.

Für background_job_histories (run_at), und background_jobs (last_run_at) gibt es keine Standardwerte - die werden auch überschrieben / ignoriert, wenn ich etwas eintrage. Ich vermute daher, dass es irgendeinen Code gibt, der dafür sorgt, dass die Jobs 2 Stunden zu spät gestartet und anschließend "falsch" protokolliert werden.
Ich bin leider nicht so fit, dass ich den Perl-Code nach Auffälligkeiten durchforsten könnte.

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
2 Antworten
0 Punkte
2 Antworten
Gefragt 24, Jun 2013 von leo_kivi (940 Punkte)
0 Punkte
1 Antwort
...