Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Unterstützt kivitendo mit der Basis-Subskription!

0 Punkte

Hallo Allerseits,

ich versuche gerade in einer frisch neu aufgesetzten Debian 12-VM Kivitendo 3.9.0 zu installieren und folge dabei der Dokumentation.

  • Installation der benötigten Pakete (Doku-Abschnitt 2.2.2.1) -> ok
  • Installation der LaTex-Pakete (Doku-Abschnitt 2.14) -> ok

Ein Aufruf von "./scripts/installation_check.pl --latex --install-command" zur Prüfung der Installation auf ev. fehlende Pakete gibt das hier aus:

root@debian-kivi-dev:/opt/kivitendo/kivitendo-erp#  ./scripts/installation_check.pl --latex --install-command
Looking for LaTeX kpsewhich ................................................. ok
Looking for LaTeX package pdfx .............................................. ok
sh: 1: latexmk: not found
Looking for pdfx version 2018 or higher ................................. NOT ok

Checking LaTeX Dependencies for Master Templates 'RB':
Looking for LaTeX document class scrartcl ................................... ok
Undefined subroutine &main::uniq called at ./scripts/installation_check.pl line 200.

Ein "./scripts/installation_check.pl" läuft normal durch mit am Ende

Result:
All ......................................................................... OK

Irgendwas ist kaputt. Entweder die Doku oder das Skript. Hat jemand eine Idee?

Viele Grüße!
Raimo

von (1.7k Punkte)

1 Antwort

0 Punkte
 
Beste Antwort

Hallo Raimo,
das ist ein Fehler im Script. Aber es ist zu empfehlen das latexmk zu installieren siehe Link und auch changelog da steht was dazu.

https://www.kivitendo.de/kivi/doc/html/ch02s14.html#allgemeine-hinweise-zu-latex

Beste Grüße
Werner kivitendodienstleister

Unterstütze kivitendo mit einer Basis-Subcription

von (16.9k Punkte)
ausgewählt von

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
2 Antworten
0 Punkte
1 Antwort
0 Punkte
4 Antworten
Gefragt 11, Dez 2012 von pseher (920 Punkte)
...