Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Unterstützt kivitendo mit der Basis-Subskription!

0 Punkte

Hallo,

ich versuche aktuell von 3.4.1 auf 3.5.0 upzugraden. Bekomme allerdings folgenden Meldnung.

Führe purchase_letter_rights.pl aus: Neue Rechte für Lieferantenbriefe

Die Datenbankaktualisierung/erstellung schlug fehl. Die Datei sql/Pg-upgrade2-auth/purchase_letter_rights.pl enthielt den folgenden Fehler:
Can't locate object method "new" via package "SL::DBUpgrade2::purchase_letter_rights" (perhaps you forgot to load "SL::DBUpgrade2::purchase_letter_rights"?) at /var/www/kivitendo-erp/SL/DBUpgrade2/Base.pm line 37.
Alle Änderungen in dieser Datei wurden rückgängig gemacht. 

Ich hab einfach über git pull die aktuellen Sourcen gezogen auf den Tag 3.5.0 gesetzt.

Vielen Dank schonmal

von

1 Antwort

+1 Punkt

Hi,
den Webserver nicht neu gestartet?

Im fcgi-Modus kennt der die neuen Dateien noch nicht.

P.S.: Danke für den Hinweis mit exclude alpha

happy kivi

von (17.6k Punkte)

Perfekt. Das war es.

Ähnliche Fragen

0 Punkte
2 Antworten
Gefragt 28, Mai 2015 von Anonym
0 Punkte
1 Antwort
Gefragt 3, Mär 2021 von bonzius (70 Punkte)
0 Punkte
2 Antworten
Gefragt 31, Mär 2018 von silencer2010 (970 Punkte)
0 Punkte
1 Antwort
0 Punkte
1 Antwort
Gefragt 22, Dez 2015 von Anonym
...